
Oracle  Financial Data Manager Rate Manager

Reference Guide

Release 4.5  

July 2000

Part No.  A80990-01



Oracle Financial Data Manager Rate Manager Reference Guide, Release 4.5

Part No.  A80990-01

Copyright © 1996, 2000, Oracle Corporation. All rights reserved. 

Primary Author: Lauren Sternberg

Contributing Authors: Flora Kidani, Rondi Mertes

The Programs (which include both the software and documentation) contain proprietary information of 
Oracle Corporation; they are provided under a license agreement containing restrictions on use and 
disclosure and are also protected by copyright, patent, and other intellectual and industrial property 
laws. Reverse engineering, disassembly, or decompilation of the Programs is prohibited. Program 
documentation is licensed for use solely to support the deployment of the Programs and not for any 
other purpose.

The information contained in this document is subject to change without notice. If you find any problems 
in the documentation, please report them to us in writing. Oracle Corporation does not warrant that this 
document is error free. Except as may be expressly permitted in your license agreement for these 
Programs, no part of these Programs may be reproduced or transmitted in any form or by any means, 
electronic or mechanical, for any purpose, without the express written permission of Oracle Corporation.

If the Programs are delivered to the U.S. Government or anyone licensing or using the programs on 
behalf of the U.S. Government, the following notice is applicable:

Restricted Rights Notice  Programs delivered subject to the DOD FAR Supplement are "commercial 
computer software" and use, duplication, and disclosure of the Programs, including documentation, 
shall be subject to the licensing restrictions set forth in the applicable Oracle license agreement. 
Otherwise, Programs delivered subject to the Federal Acquisition Regulations are "restricted computer 
software" and use, duplication, and disclosure of the Programs shall be subject to the restrictions in FAR 
52.227-19, Commercial Computer Software - Restricted Rights (June, 1987). Oracle Corporation, 500 
Oracle Parkway, Redwood City, CA 94065.

The Programs are not intended for use in any nuclear, aviation, mass transit, medical, or other inherently 
dangerous applications. It shall be the licensee's responsibility to take all appropriate fail-safe, backup, 
redundancy, and other measures to ensure the safe use of such applications if the Programs are used for 
such purposes, and Oracle Corporation disclaims liability for any damages caused by such use of the 
Programs. 

Oracle is a registered trademark, and Oracle Budgeting & Planning, Oracle Customer Householding, Ora-
cle Financial Data Manager, Oracle Financial Data Manager Administration, Oracle Financial Data Man-
ager Balance & Control, Oracle Financial Data Manager Data Dictionary, Oracle Financial Data 
Manager/Discoverer Integrator, Oracle Financial Data Manager Rate Manager, Oracle Performance Ana-
lyzer, Oracle Risk Manager, and Oracle Transfer Pricing are trademarks or registered trademarks of Oracle 
Corporation.



iii

Contents

Send Us Your Comments ..................................................................................................................    vii

Preface............................................................................................................................................................    ix

1 Introduction

What is Rate Manager? ......................................................................................................................    1-1
Overview of Oracle Financial Services Applications ..................................................................    1-1

Oracle Financial Data Manager ..................................................................................................    1-2
OFS Applications..........................................................................................................................    1-3

Logging In to Rate Manager .............................................................................................................    1-4
Using the Main Interface...................................................................................................................    1-4

Window and Navigation Trees ..................................................................................................    1-5
Menu Bar........................................................................................................................................    1-5

File Menu ................................................................................................................................    1-6
Edit Menu ...............................................................................................................................    1-6
Actions Menu.........................................................................................................................    1-6
Tools Menu.............................................................................................................................    1-7
Window Menu.......................................................................................................................    1-7
Help Menu..............................................................................................................................    1-7

Icons................................................................................................................................................    1-7

2 Overview of Rate Manager

Managing Currencies .........................................................................................................................    2-1
Managing Interest Rates....................................................................................................................    2-2



iv

Managing Exchange Rates ................................................................................................................    2-2

3 Managing Currencies

Using the Currencies Tree .................................................................................................................    3-1
Currency Definitions and Classifications..................................................................................    3-2

The Functional Currency......................................................................................................    3-2
Reporting Currencies ............................................................................................................    3-2
Other Active Currencies .......................................................................................................    3-2

Activating/Deactivating a Currency .........................................................................................    3-3
Adding a Currency.......................................................................................................................    3-4
Deleting a Currency......................................................................................................................    3-5

Using the Currency Pane ...................................................................................................................    3-5

4 Managing Interest Rates

Using the Interest Rate Codes Tree .................................................................................................    4-1
Adding an Interest Rate Code.....................................................................................................    4-1
Deleting an Interest Rate Code ...................................................................................................    4-3

Using the Interest Rate Code Pane ..................................................................................................    4-4
The Attributes Tab........................................................................................................................    4-4
The Terms Tab...............................................................................................................................    4-5

Rules for Adding New Terms..............................................................................................    4-5
Adding a Term.......................................................................................................................    4-6
Deleting a Term .....................................................................................................................    4-6

The Rates Tab ................................................................................................................................    4-7
Inputting Interest Rates ........................................................................................................    4-7
Modifying or Deleting Interest Rates .................................................................................    4-8
Viewing and Printing Interest Rates...................................................................................    4-8

The Parameters Tab ......................................................................................................................    4-9
Restrictions on Input Values..............................................................................................    4-10
Inputting Parameter Data...................................................................................................    4-10
Modifying or Deleting Parameter Data............................................................................    4-11
Viewing and Printing Parameters.....................................................................................    4-11



v

5 Managing Exchange Rates

Using the Exchange Rates Tree.........................................................................................................    5-1
The Floating Rates Node .............................................................................................................    5-1
The Fixed Rates Node ..................................................................................................................    5-2
Adding Exchange Rate Relationships .......................................................................................    5-3

Adding a Floating Exchange Rate Relationship ...............................................................    5-3
Adding a Fixed Exchange Rate Relationship ....................................................................    5-4

Deleting Exchange Rate Relationships ......................................................................................    5-5
Deleting a To or Parent Currency Node ............................................................................    5-5
Deleting a From or Child Currency Node .........................................................................    5-6

Using the Floating Multiple Exchange Rates Pane ......................................................................    5-6
Adding Floating Exchange Rates to Existing Relationships ..................................................    5-7

In the To Currency Pane.......................................................................................................    5-7
In the From Currency Pane..................................................................................................    5-7

Viewing and Printing Floating Exchange Rate History..........................................................    5-8
Modifying or Deleting Floating Exchange Rate History ........................................................    5-8

In the To Currency Pane.......................................................................................................    5-8
In the From Currency Pane..................................................................................................    5-9

Using the Fixed Multiple Exchange Rates Pane ...........................................................................    5-9
Adding Fixed Exchange Rates to Existing Relationships .....................................................    5-10

In the Parent Currency Pane..............................................................................................    5-10
In the Child Currency Pane ...............................................................................................    5-11

Viewing and Printing Fixed Exchange Rate History.............................................................    5-11
Modifying or Deleting Fixed Exchange Rate History ...........................................................    5-11

In the Parent Currency Pane..............................................................................................    5-11
In the Child Currency Pane ...............................................................................................    5-12

Validating Exchange Rate Relationships .....................................................................................    5-12
Exchange Rate Validation Criteria ...........................................................................................    5-13
Running an Exchange Rate Validation....................................................................................    5-14
Viewing the Messages................................................................................................................    5-15

Index



vi



vii

Send Us Your Comments

Oracle Financial Data Manager Rate Manager Reference Guide, Release 4.5   

Part No.  A80990-01

Oracle Corporation welcomes your comments and suggestions on the quality and usefulness of this 
document. Your input is an important part of the information used for revision.

■ Did you find any errors?
■ Is the information clearly presented?
■ Do you need more information? If so, where?
■ Are the examples correct? Do you need more examples?
■ What features did you like most?

If you find any errors or have any other suggestions for improvement, please indicate the document 
title and part number, and the chapter, section, and page number (if available). You can send com-
ments to us in the following ways:

■ Electronic mail - fsdocmail@us.oracle.com
■ FAX - (650) 506-7200   Attn:  Oracle Financials Documentation Manager
■ Postal service:

Oracle Corporation 
Oracle Financials Documentation Manager
500 Oracle Parkway
Redwood Shores, CA  94065
USA

If you would like a reply, please give your name, address, telephone number, and (optionally) elec-
tronic mail address.

 If you have problems with the software, please contact your local Oracle Support Services.



viii



ix

Preface

This reference guide describes the features and benefits of Oracle Rate Manager and 
explains how to use it. 

The preface covers these topics:

■ Intended Audience

■ Organization

■ Related Documents

■ Conventions

■ Customer Support

Intended Audience
Rate Manager is designed to be used by finance professionals within the financial 
services industry. Therefore, this guide assumes you are familiar with terms and 
concepts related to interest rates and currency exchange. It also assumes that Rate 
Manager has been properly installed on your client/server system.
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Organization
This guide contains the following chapters: 

There is also an index.

Related Documents
For more information about the database structure supporting Rate Manager, refer 
to these documents:

■ Oracle Financial Data Manager Administration Guide

■ Oracle Financial Data Manager Data Dictionary

■ Oracle Financial Services Technical Reference Manual

If you have installed other OFS applications, refer to their reference guides.

Chapter Description

1 Introduction Describes the role of the database, the Rate Manager 
utility, and Oracle Financial Services (OFS) 
applications. Explains how to access Rate Manager 
and describes the layout and function of the main 
user interface.

2 Overview of Rate Manager Provides an overview of Rate Manager features and 
benefits.

3 Managing Currencies Explains how to activate, edit, add, and delete 
currency codes.

4 Managing Interest Rates Explains how to add, modify, and delete new interest 
rate codes and manage term structure parameters.

5 Managing Exchange Rates Explains how to add, modify, and delete fixed and 
floating exchange rates, and to run the exchange rate 
validation process. 
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Conventions
The following typographic conventions are used throughout the guide: 

Customer Support
You can obtain support for this product through Oracle Support Services. Contact 
your project manager for information about the support options available in your 
locale. These options may include:

■ MetaLink, which provides online access to information about technical libraries, 
patches, technical assistance requests (TARs), and bugs, and is available at 
metalink.oracle.com

■ Telephone support

Convention Description

[ ] Brackets enclose the names of keyboard keys.

boldface text Boldface type in text indicates a term defined in the text. 

Italics Italics emphasize a word or phrase.

-> An arrow indicates a menu path.

■ Bullets are used for lists of items or topics. They also indicate a choice 
of actions for performing a procedure step.

1. Numbered lists are used for steps in a procedure.

Note: Interesting but incidental information about the product, or 
information that may be important but of lesser degree than a 
Caution. 

Caution: Indicates the possibility of damage to a product, system, or data.
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1
Introduction

This chapter covers the following topics:

■ What is Rate Manager?

■ Overview of Oracle Financial Services Applications

■ Logging In to Rate Manager

■ Using the Main Interface

What is Rate Manager?
Rate Manager is a rate management utility enabling you to manage complete inter-
est rate, exchange rate, and currency data with a high degree of security and con-
trol. As part of the Financial Data Manager (FDM) database, it expands upon and 
replaces the Historical Rates ID and serves all applications in the Oracle Financial 
Services group.

Overview of Oracle Financial Services Applications
OFS applications, together with the FDM database, form a comprehensive decision 
support solution for financial institutions because they significantly enhance 
transfer pricing, budgeting and planning, risk management, and performance 
measurement capabilities.

The following diagram shows the relationship of the FDM database, its utilities, and 
the OFS applications.
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Oracle Financial Data Manager 
Oracle Financial Data Manager (FDM) is a standalone data warehouse with 
prepackaged data for the financial services industry. It provides the necessary 
support for individual OFS applications. 

FDM includes these utilities:

Oracle Financial Data Manager Balance & Control 
Balance & Control validates, corrects, and aggregates data from the FDM.

Oracle Financial Data Manager Administration 
FDM Administration manages the FDM, providing security and maintenance 
capabilities.

Oracle
Financial Data

Manager

Oracle Financial
Data Manager
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Oracle Financial
Data Manager

Balance &
Control

Oracle Transfer
Pricing

 Oracle
Performance

Analyzer

 Oracle Risk
Manager

Oracle Financial
Data Manager
Rate Manager

Oracle
Customer
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Planning
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Discoverer
Integrator
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Oracle Financial Data Manager/Discoverer Integrator
Discoverer Integrator integrates the FDM database with Oracle Discoverer, which 
provides ad hoc reporting, analysis, and Web publishing capabilities.

Oracle Financial Data Manager Rate Manager
FDM Rate Manager manages interest rate, exchange rate, and currency information 
for the FDM.

OFS Applications
The FDM database and utilities support the following applications:

Oracle Budgeting & Planning
Budgeting & Planning provides performance-based planning. It integrates cash 
flow balance sheet and net income forecasting capabilities with the scalability and 
customizable framework of Oracle Financial Analyzer, part of the Oracle Express 
group of data access and analysis tools.

Oracle Transfer Pricing 
Transfer Pricing calculates a transfer rate for each account and a charge or credit for 
funds for each asset or liability.

Oracle Performance Analyzer
Performance Analyzer provides comprehensive and flexible cost and equity 
allocations. It measures product, business unit, and customer profitability.

Oracle Risk Manager
Risk Manager forecasts cash flows and interest income, and forecasts and calculates 
market value in order to manage rate risk.

Oracle Customer Householding
Customer Householding provides a fully scalable parallel-processing engine for 
customer data loading and cleansing, customer relationship linking, 
customerization and householding, and data aggregation within FDM.
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Logging In to Rate Manager
If you are running multiple OFS applications in Windows NT or Windows 95, then 
each should have its own memory space. For more information on installation and 
configuration refer to the Oracle Financial Data Manager Installation and Configuration 
Guide.

To log in to Rate Manager:

1. Double-click the appropriate icon.

2. In the Login dialog box, enter your user name and password and select a 
database connection from the pull-down menu.

3. Click Connect or press Enter.

Using the Main Interface
This section explains how to use the following components of the main interface:

■ Window and Navigation Trees

■ Menu Bar

■ Icons
.
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Window and Navigation Trees
When you open Rate Manager the Rate Manager window appears. It contains a 
navigation structure, called the Rate Manager tree, which has three branches or 
subnodes:

■ Interest Rate Codes

■ Currencies

■ Exchange Rates

A second tier of nodes appears when you click a branch. For example, the Interest 
Rate Codes branch produces a list of interest rate types stored in the database. The 
Currencies branch produces subnodes labeled Functional Currency, Reporting 
Currencies, and Other Active Currencies. The Exchange Rates branch has subnodes 
labeled Floating Rates and Fixed Rates. 

Because the branches contain subnodes they are trees in their own right. Therefore, 
this guide refers to the Interest Rate Codes tree, Currencies tree, and Exchange Rates 
tree.

You can open as many windows as you need. Each contains a Rate Manager tree. 

For more information on trees and nodes see Chapter 3, "Managing Currencies"; 
Chapter 4, "Managing Interest Rates"; and Chapter 5, "Managing Exchange Rates".

Menu Bar
The menu bar contains these pull-down menus: 

■ File

■ Edit

■ Actions

■ Tools

■ Window

■ Help
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File Menu
The File menu contains the New, Print, and Exit commands. The New command 
offers several options.

Edit Menu

Actions Menu

Command Description

New Select from the following options: 

■ Window: To open a new window to access data, 
perform calculations, and make side-by-side 
comparisons.

■ Interest Rate Code: To add a new interest rate code.

■ Currency Code: To define a new currency code.

■ Fixed Exchange Rate: To define a fixed exchange rate 
between any two active currencies.

■ Floating Exchange Rate: To define a floating 
exchange rate between active currencies.

Print Prints the contents of an open spreadsheet. If you are 
viewing a graph, both the graph and the corresponding 
spreadsheet are printed.

Exit Closes and exits Rate Manager.

Command Description

Delete Deletes selected nodes in the Interest Rate Code and 
Exchange Rate trees.

Activate and Deactivate 
Currencies

Enables you to activate or deactivate the currencies you 
want to work with.

Command Description

Refresh Object Erases changes to a window pane before they are saved, 
and restores the previously saved view. It is an 
alternative to the Reset command.
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Tools Menu

Window Menu

Help Menu

Icons
There are four icons in the title bar and nine in the toolbar. All are preset and cannot 
be changed.

The icons in the title bar follow Windows conventions. The one on the left produces 
a drop-down menu that enables you to adjust screen size and exit Rate Manager. 

Command Description

Run Leads to the Exchange Rate Validation command, which 
launches the process of validating newly entered 
exchange rates.

Schedule Enables you to schedule the exchange rate validation 
process.

Messages Displays messages generated during exchange rate 
validations.

Command Description

Cascade Places one window on top of another diagonally.

Tile Horizontally Splits the screen so that a portion of one open window 
appears above another.

Tile Vertically Divides the screen so that open windows appear side by 
side

Command Description

Window Help TOC Launches an online help function. The table of contents 
(TOC) appears.

Window Help Index Displays the index of topics available. 

About Oracle Applications Identifies the Rate Manager version, copyright, current 
user and database.
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The three on the right enable you to minimize the screen, restore the screen to its 
previous size, and exit the window, respectively.

The toolbar contains these icons:

Icon Description

1 New Currency Produces the New Currency dialog box, 
enabling you to define a new currency code.

2 New Interest Rate Code Produces the New Interest Rate Code dialog 
box, enabling you to define a new interest rate 
code.

3 New Floating Exchange Rate Produces the New Floating Exchange Rate 
dialog box, enabling you to define a new 
floating exchange rate relationship.

4 New Fixed Exchange Rate Produces the New Fixed Exchange Rate dialog 
box, enabling you to define a new fixed 
exchange rate relationship.

5 Run Exchange Rate Validation Launches the exchange rate validation process.

6 Scheduler Enables you to schedule one or recurring 
exchange rate validation jobs.

7 Delete Selected Item From Tree Deletes the selected node from the tree.

8 Print Prints the contents of a spreadsheet. If you are 
viewing a graph, both the graph and the 
spreadsheet are printed.

9 Help Launches the online help function.

1 3 5 7 9

2 4 6 8
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2
Overview of Rate Manager

Rate Manager enables you to manage currencies, interest rates, and exchange rates 
more easily. In doing so, you can:

■ Define and select currencies for processing.

■ Define and manage interest rates for modeling purposes.

■ Enter, track, and validate currency exchange rates.

This chapter provides an overview of these areas. They are discussed in detail in the 
following chapters.

Managing Currencies
Rate Manager handles all currency definitions for OFS applications. Currencies are 
conveniently referred to by code and written description. A comprehensive list of 
ISO-defined currencies is included, and you can define and add your own.

Upon installation one currency is active and ready for processing: the one identified 
by your organization as the functional currency. You can activate other currencies 
and define and activate newly-created currencies when needed. In addition, you 
can designate key currencies to be used for reporting. These alone will be available 
for cross-currency consolidation.

For more information about managing currencies, see Chapter 3, "Managing 
Currencies".
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Managing Interest Rates
The quality and availability of interest rate information varies throughout the 
world. In many markets, gathering comprehensive rate information is a challenge 
because of insufficient security types, inconsistent quoting conventions, and lack of 
liquidity. 

Rate Manager facilitates the process of inputting and viewing interest rates and 
yields by supporting multiple rate formats and other rate attributes to give you data 
storage capabilities appropriate to your market. For example, you can store the 
following data attributes:

■ Rate format (zero-coupon or yield-to-maturity)

■ Accrual basis

■ Compound basis

Term structure parameters provide insight into the stability and direction of future 
rates. Rate Manager enables you to define and store—up to daily—term structure 
parameters for any and all currently supported term structure models.

For more information about managing interest rates, see Chapter 4, "Managing 
Interest Rates".

Managing Exchange Rates
You can define, input, and maintain exchange rates between any two active curren-
cies. In addition to the standard floating exchange relationships special fixed rela-
tionships are available, such as those within the European Monetary Union (EMU). 
Rate Manager complies with EMU structure and legislation, and supports changes 
in currency rates as well as additions and deletions of member countries’ currencies.

For more information about managing exchange rates, see Chapter 5, "Managing 
Exchange Rates".
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3
Managing Currencies

The chapter contains two sections:

■ Using the Currencies Tree

This section explains how currencies are classified and identified within Rate 
Manager, and how to activate, deactivate, add and delete currencies for 
processing purposes.

■ Using the Currency Pane

This section explains how to access and edit currency attributes.

Using the Currencies Tree
The Currencies tree enables you to select currencies for reporting and for 
establishing interest rates and exchange rates. It consists of three branches: 

■ Functional Currency

■ Reporting Currencies

■ Other Active Currencies
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When you click a branch it expands to produce nodes for each currency in that 
classification. Before defining the classifications, let’s begin by discussing two types 
of currencies: ISO-defined and user-defined.

Currency Definitions and Classifications
Rate Manager provides a list of ISO-defined currencies for you to activate as 
needed. (The functional currency is activated upon installation.) You can also define 
and add your own. Any currency except the functional currency can be deactivated 
or deleted.

Currencies are displayed on the tree in alphabetical order by description. They fall 
into three classifications: 

■ The functional currency

■ Reporting currencies

■ Other active currencies

The Functional Currency
At the time of installation, Rate Manager requires the installer to designate a 
functional, or primary, currency for the organization. A Swiss multinational bank 
would therefore designate the Swiss franc as its functional currency. Only one 
functional currency is allowed per organization, and once assigned it cannot be 
changed. The functional currency is both an active and a reporting currency. 

Reporting Currencies
A reporting currency is an active currency that balances in other currencies are 
consolidated to, to facilitate reporting. Balances in reporting currencies are, in turn, 
consolidated to the functional currency. For example, an American multinational 
bank might consolidate its holdings in Asian currencies to the Japanese yen and its 
balances in European currencies to the Euro. Then it would consolidate the sums to 
the U.S. dollar.

Other Active Currencies
An active currency is one an organization works with. When Rate Manager is 
installed only the functional currency is active and available for processing. If your 
institution has holdings in more than one currency then you need to activate those 
currencies. A Mexican bank doing business in the United States and Canada, for 
instance, would activate the U.S. dollar and the Canadian dollar.
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Activating/Deactivating a Currency
To activate or deactivate a currency, do the following:

1. From the Edit menu, select Activate/Deactivate Currencies.

The Activate/Deactivate Currencies dialog box appears. Locate the currency 
code you want from the appropriate list.

2. Select one or more currencies in the following manner:

■ To select one currency, click its code. Then click the appropriate angle 
bracket button (> or <) to move the code to the desired list.

■ To select two or more currencies, click one and press the [Ctrl] key. While 
holding [Ctrl], click any others you want. Click the appropriate angle 
bracket button. 

■ To select two or more currencies codes sequentially in the list, click one and 
press the [Shift] key. While holding [Shift], press the up or down arrow key 
or use the scroll bar, and click another currency code. Release [Shift] and 
click the appropriate angle bracket button.

■ To select all codes in the list, click the appropriate double angle bracket 
button (>> or <<).

Note: The functional currency cannot be deactivated.
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After you click the appropriate angle bracket button, your selection appears in 
the new list.

3. Click OK to save your change, or Cancel to exit without saving. 

Adding a Currency
To add a user-defined currency to the database:

1. Do one of the following:

■ From the File menu, select New -> Currency Code.

■ Right-click the Currencies node and subnodes (except the Functional 
Currencies branch). A menu appears. Click New -> User Defined Currency.

■ Click the New Currency icon.

The New Currency dialog box appears.

2. In the Currency Code Value field, enter a code for the new currency.

3. In the Description field, enter a description of the new currency.

4. If you want the new currency to be used for reporting, then click the Reporting 
Currency check box. 

To remove the check mark, click the box again.

5. Click OK or Cancel.

Note: A currency code must have exactly three characters and not 
begin with 0. Rate Manager does not accept code values begin-
ning with 0 because it reserves them for internal processing.
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Once a currency code is saved it cannot be changed.

Deleting a Currency
Before you delete a currency, keep the following in mind:

■ Deleting a currency deletes all records associated with it.

■ You cannot delete the functional currency or any currency that is referenced by 
one or more interest rate codes. Attempting to do so will trigger a warning 
message.

■ If you want to delete a currency that is referenced by at least one interest rate 
code, then you must first select another reference currency for that interest rate 
code or codes.

To delete a currency:

1. In the Currencies subnode (except Functional Currency), locate the currency 
code you want to delete.

2. Do one of the following:

■ Click the currency code. Then click the Edit menu and select Delete.

■ Right-click the currency code. In the resulting menu, click Delete.

■ Click the Delete Selected Item From Tree icon.

The Delete warning appears, asking you to confirm your decision. 

3. Click Yes to delete that currency, or No to escape. 

Using the Currency Pane
Clicking a branch of the Currencies tree produces a tier of subnodes, one for each 
currency in the category. Clicking a subnode displays a pane containing these 
currency attributes:

■ Description 

■ Reference Interest Rate Code

■ Reporting Currency check box

All of these attributes can be edited.
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Description
The name of the currency appears in the Description field. To edit it, input the new 
description and click Apply. Clicking Reset deletes your change and restores the 
previous description.

Reference Interest Rate Code
The reference interest rate code determines the indicator for interest rate levels in 
that currency. For example, the risk-free curve in the U.S. is the U.S. Treasury curve. 
The Treasury curve should therefore be tied to the U.S. dollar. 

The default for this field is <None>. When you assign one or more reference interest 
rate codes in that currency, the field becomes a drop-down list.

For more information on interest rate codes, see Chapter 4, "Managing Interest 
Rates".

Reporting Currency Check Box
This box contains a check mark if the currency is to be used in reporting. You can 
check it or uncheck it.
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4
Managing Interest Rates

This chapter contains the following sections:

■ Using the Interest Rate Codes Tree

This section explains how to add and delete interest rate codes.

■ Using the Interest Rate Code Pane

This section explains how to use the Attributes, Terms, Rates, and Parameters 
tabbed pages to manage interest rate data.

Using the Interest Rate Codes Tree
Clicking the Interest Rate Codes tree produces a second tier of nodes, one node for 
each interest rate code in the database. The nodes are arranged alphabetically by 
description.

Adding an Interest Rate Code
To define and add an interest rate code:

1. Do one of the following:

■ From the File menu, click New -> Interest Rate Code.

■ Click the New Interest Rate Code icon in the toolbar.

■ Right-click the Interest Rate Codes tree node. Then click New -> Interest 
Rate Code.
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The New Interest Rate Code dialog box appears.

2. In the Interest Rate Code field, input a numeric code value.
.

3. In the Interest Rate Code Description field, input a description of the code.

4. In the Rate Format field, choose either Zero Coupon Yield (the default) or click 
the drop-down menu to select Yield to Maturity.

5. From the Compound Basis drop-down menu, select a compound basis: Annual 
(the default), Semiannual, Monthly, or Simple. 

6. Choose an accrual basis from the Accrual Basis drop-down menu.

Note: The range of valid code values is 1 to 99999.

Compound Basis Accrual Bases

Annual, Semiannual, or 
Monthly

Actual/Actual (default)

30/365

Actual/365
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7. From the Reference Currency drop-down menu, choose the currency in which 
you want to define interest rates. 

8. In the Term Point field, choose a term point.

9. From the Multiplier pull-down menu, select either Months, Days, or Years. (The 
default is Months.)

10. Click OK to save changes or Cancel to exit without saving changes.

The new interest rate code appears as a node on the Interest Rate Codes tree.

Deleting an Interest Rate Code
Before deleting a node, remember that doing so deletes all interest rate and term 
structure parameter history for that interest rate code.

1. Locate the appropriate node on the Interest Rate Codes tree.

2. Select one of these options:

■ Right-click the node. Then click Delete.

■ Click the Edit menu -> Delete. 

■ In the tool bar, click the Delete Selected Item from Tree icon.

Simple 30/360 (default)

Actual/360

Actual/Actual

30/365

30/Actual

Actual/365

Note: Only active currencies are listed. For more information 
about active currencies, see Chapter 3, "Managing Currencies".

Note: You can add more terms after you have created and saved 
the interest rate code. The Terms tab is used for this purpose.

Compound Basis Accrual Bases
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The Delete dialog box appears.

3. Click Yes to confirm the deletion or No to escape.

Using the Interest Rate Code Pane
When you click a node on the Interest Rate Codes tree, a pane with four tabbed 
pages appears to the right of the tree. The pages display interest rate code 
characteristics and enable you to input, modify, and view data. The tabs are 
Attributes, Terms, Rates, and Parameters.

The Attributes Tab
The Attributes page summarizes the attributes of the interest rate code. While it is 
not recommended, you can change any attribute except for the code value.
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The Terms Tab
The Terms page displays the term structure for your interest rate code. You can 
modify the structure by adding or deleting term points.

Rules for Adding New Terms
Rate Manager safeguards the integrity of your data by rejecting new terms that 
overlap existing ones. Please note these restrictions:

■ The maximum number of daily points is 731.

■ A new daily point will be rejected when its frequency falls within the range of 
an existing term having a monthly or yearly equivalent. For example, a new 
term of 28, 29, 30, or 31 days will be rejected when there is an existing term of 
one month.

■ Likewise, a new monthly term will be refused when its frequency falls within 
the range of an existing daily or yearly equivalent. A new term of one month 
will be rejected when a daily point of 28, 29, 30, or 31 already exists.

■ A new monthly point will be refused when, divided by 12, it overlaps an 
existing yearly point. For example, a new term of 36 months duplicates an 
existing term of three years.

■ A new yearly point must not equal an existing monthly point divided by 12. For 
example, a new term of two years equals an existing term of 24 months.
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Adding a Term
1. On the Interest Rate Codes tree, select your Interest Rate Code node. 

2. In the Terms tabbed page, click Add Row.

The Define a Term dialog box appears.

3. Enter a term point and select a multiplier from the pull-down menu.

4. Add more terms by repeating steps 1 through 3.

5. Click OK to submit the data.

A new row appears for each term submitted. The data is printed in red.

Data is rejected when it violates the restrictions stated previously. An error 
message is displayed.

6. Click Apply to save your change or Reset to discard it.

The data changes from red to black when it is accepted.

Deleting a Term
Deleting a term deletes all interest rate history for it.

1. Select the Interest Rate Code node you want. 

2. In the Terms tabbed page, click the row you want to delete and click Delete 
Row. 

The Delete warning box appears, asking you to confirm your choice.

3. Click Yes or No. 

Clicking Yes causes the data to appear gray.

4. To delete additional terms, repeat steps 2 and 3.

5. Click Apply to delete the row or Reset to cancel the action.
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The Rates Tab
The Rates page enables you to enter, modify, or delete interest rates for new dates 
and to view them in a spreadsheet and on a graph.

Inputting Interest Rates
To enter interest rates for an Interest Rate Code:

1. On the Interest Rate Codes tree, click the appropriate node.

2. Click the Rates tabbed page.

A table appears in the Interest Rates area. Rates for each term are listed by 
effective date. 

3. Click the Add Row button.

A row is added to the table. The current date appears in the row by default.

4. Adjust the date if necessary by highlighting the year, month, or day and 
clicking the up or down arrow. You can use the arrow keys (on your keyboard) 
to move left or right.

5. In the new row, key in interest rates. Press Enter or tab out of cells.
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.

6. Click Apply to save your changes or Reset to eliminate them.

7. Add rows by repeating steps 3 through 6.

Modifying or Deleting Interest Rates
To modify or delete interest rates:

1. On the Interest Rate Codes tree, click the node of the interest rate code you want 
to modify.

2. Click the Rates tabbed page.

3. Click the rate you want to modify or delete.

4. Change or delete the rate. To delete all rates for a certain date, click Delete Row 
while anywhere in that row.

5. Click Apply to enter the change or deletion, or Reset to restore the previous 
data.

Viewing and Printing Interest Rates
Rate Manager displays a spreadsheet of data for the last month unless you specify 
otherwise. To see rates for the last three years, for example, go to the select a date 
range pull-down menu and click Last 3 Years. To view the entire table, click All.

Viewing a Graph To see your selected table view displayed as a graph, click the 
Display Graph check box. The graph appears on top of the spreadsheet.

The horizontal axis shows the dates within your chosen time frame. The vertical 
axis shows the range of interest rates. Interest rate history for each term is plotted 
accordingly.

Note: The range of valid rates is -999.9999% to 999.9999%. To enter 
a rate of 5.2%, for instance, input 5.2.
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Printing To print a copy of the spreadsheet, do one of the following. 

■ Click File -> Print.

■ Click the Print icon.

If you are viewing a graph, Rate Manager prints the graph followed by the 
spreadsheet.

The Parameters Tab
Rate Manager centralizes and maintains the following parameters, which are 
needed for stochastic modeling of interest rates in Risk Manager and Transfer 
Pricing: 

■ Mean reversion speed

■ Long run rate

■ Merton volatility

■ Vasicek volatility

Merton volatility is needed for the Merton and Ho and Lee term structure models. 
Vasicek volatility is needed for the Vasicek and Extended Vasicek models.
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Values for long run rate and volatility are assumed to be percentages. For example, 
a long run rate of 5% is displayed as 5.000.

You might prefer to input parameters manually for As-of- Date processing in Risk 
Manager.

Restrictions on Input Values
To maintain the integrity of your data, Rate Manager restricts the input values it 
accepts. Note the valid range and default setting for each parameter

Inputting Parameter Data
To input parameter data for the current date:

1. Click the Add Row button.

A new row is added to the Defined Parameters table. The current date appears 
in the Effective Date field.

Parameter Valid Range Default

Mean reversion speed 0 to 10.0 0

Long run rate 0 to 999.9999% 0

Volatility (both Merton and Vasicek) 0.01% to 10.0% 0.01%
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2. Input values for the parameters.

3. Click Apply or Reset.

The Rate Data Source Code field tells whether parameters were entered 
manually (User Input) or otherwise (not available in release 4.5). It cannot be 
edited. 

Modifying or Deleting Parameter Data
1. Click the row to be modified or deleted.

2. Click Delete Row.

The row appears gray.

3. Click Apply to complete the deletion or Reset to escape.

Viewing and Printing Parameters
Rate Manager displays data for the last month unless you select otherwise from the 
select a date range pull-down menu. 

To print the spreadsheet, do one of the following:

■ Click File -> Print.

■ Click the Print icon.

Note: If you use only the Merton or Ho and Lee models, then the 
only parameter you need to specify is Merton Volatility. You can 
leave other parameters at their default values.
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5
Managing Exchange Rates

This chapter contains the following sections:

■ Using the Exchange Rates Tree

This section explains how the Exchange Rates tree is structured, and how to 
add, modify, and delete exchange rate relationships.

■ Using the Floating Multiple Exchange Rates Pane 

This section explains how to add, modify, and delete floating exchange rates, 
and how to view and print exchange rate relationship data in a spreadsheet and 
a graph.

■ Using the Fixed Multiple Exchange Rates Pane

This section explains how to add, modify, and delete fixed exchange rates, and 
how to view and print exchange rate relationship data.

■ Validating Exchange Rate Relationships

This section explains how to run the exchange rate validation process.

Using the Exchange Rates Tree
The starting point for managing exchange rates is the Exchange Rates tree. Clicking 
it produces two subnodes, labeled Floating Rates and Fixed Rates, respectively.

The Floating Rates Node
Floating, or standard, exchange rates are market driven, such as those between the 
U.S. dollar (USD) and the Mexican peso (MXN). In this type of relationship, units of 
Currency A (the From currency) are converted at the floating exchange rate to one 
unit of Currency B (the To currency).
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In the following example, units of From currency are being converted at the floating 
exchange rate to one unit of To currency: 

When you click the Floating Rates subnode a second tier of nodes appears, one for 
each To currency. Clicking a To currency node produces a third tier; these are the 
From currencies having exchange rates defined for at least one date. At the same 
time a pane appears to the right. The pane contains a spreadsheet of all defined 
From currencies and their exchange rates by date. 

To separately view the history of From currency exchange rates, click its node.

The Fixed Rates Node
A fixed exchange rate expresses a special fixed relationship between two currencies.

In this example, the French franc and the Euro are pegged to each other, and units 
of the Child currency are being converted to one unit of the Parent currency:

Clicking the Fixed Rates subnode produces a second tier of nodes: these represent 
the Parent currencies. When you click a Parent currency node a third tier appears, 
one for each Child currency in the relationship. A pane appears to the right, which 
contain a spreadsheet of Child currencies and the exchange rates by date.

To view a Child currency pane, click its node.

Units of From Currency
At the Floating 
Exchange Rate Equal One Unit of To Currency

USD 0.1045 MXN

MXN 9.5720 USD

Units of Child Currency
At the Fixed 
Exchange Rate Equal One Unit of Parent Currency 

FRF 6.5595 EUR

EUR 0.1525 FRF
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Adding Exchange Rate Relationships
You can add an exchange relationship between any two active currencies. To 
activate a currency, refer to Chapter 3, "Managing Currencies".

Adding a Floating Exchange Rate Relationship
To add a new floating exchange rate relationship:

1. Do one of the following:

■ Click File -> New -> Floating Exchange Rate.

■ Click the New Floating Exchange Rate icon.

■ Right-click the Exchange Rates branch of the Rate Manager tree. Then click 
New -> Floating Exchange Rate.

■ Right-click the Floating Exchange rate branch, then click New -> Floating 
Exchange Rate.

The New Floating Exchange Rate dialog box appears.

2. In the From Currency pull-down menu, select a From currency.

3. In the To 1 unit of pull-down menu, select a To currency.

4. In the Exchange Rate field, input the exchange rate.

Note: The valid range is 0 to 999999.999999999%. In general, 
inputting a rate of 0 is not recommended.
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5. In the Effective Date field, today’s date appears by default. If necessary, enter 
the effective date of the exchange rate.

6. Click OK to save your data, or Cancel to escape.

The new To currency node appears on the Floating Rates branch. The From 
currency node is a level below the To node. If the To currency node was already 
on the tree, then the From node is added to it.

Adding a Fixed Exchange Rate Relationship
1. Do one of the following:

■ Click File -> New -> Fixed Exchange Rate.

■ Click the New Fixed Exchange Rate icon.

■ Right-click the Exchange Rates branch of the Rate Manager tree. Then click 
New -> Fixed Exchange Rate.

■ Right-click the Fixed Exchange branch, then click New -> Fixed Exchange 
Rate.

The New Fixed Exchange Rate dialog box appears.

2. In the Child Currency pull-down menu, select a Child currency.

3. In the per 1 unit of Parent Currency pull-down menu, select a Parent currency.

Note: Only one rate can be entered per date. Entering a duplicate 
date triggers an error message.
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4. In the Begin Date field, enter a beginning date for the relationship.

5. In the End Date field, select one:

■ If the end date of the relationship is unknown, do nothing. The default 
setting is None and the date field remains blank.

■ If you know the end date, click the pull-down menu and select Set. The 
current date appears in the date field. Adjust the date if necessary.

6. In the Exchange Rate field, input the exchange rate.

7. Click OK to save your data, or Cancel to escape.

The new Parent currency node appears on the Fixed Rates branch. The Child 
currency node is a level below the Parent. If the Parent node was already on the 
tree, then the Child node is added to it.

Deleting Exchange Rate Relationships
There are two ways to delete floating or fixed exchange rate relationships:

■ Delete a To or Parent currency node.

■ Delete a From or Child currency node.

Deleting a To or Parent Currency Node
1. Select one:

■ Right-click the node. Then click Delete.

■ Click the node. Then click Edit -> Delete.

■ Click the node. Then click the Delete icon.

A confirmation box appears.

2. Click Yes to confirm or No to exit.

The node and its records are removed from the Exchange Rates tree.

Note: The valid range is 0 to 999999.999999999%. In general, 
inputting a rate of 0 is not recommended.

Caution: Deleting a node deletes all records associated with it. 
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Deleting a From or Child Currency Node
1. Do one of the following:

■ Right-click the node. Then click Delete.

■ Click the node. Then click Edit -> Delete.

■ Click the node. Then click the Delete icon.

A dialog box appears, asking for confirmation.

2. Click Yes to confirm or No to exit.

The node and its records disappear from the Exchange Rates tree.

Using the Floating Multiple Exchange Rates Pane
When you click a To currency node, a pane appears to the right. This pane contains 
a spreadsheet and other tools for managing exchange rates for the currency.
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Adding Floating Exchange Rates to Existing Relationships
To add floating exchange rates to existing relationships, do the following:

In the To Currency Pane
1. Click the To currency node. 

2. In the pane, click the Add Row button.

A new row is added to the spreadsheet. The current date appears in the Date 
field.

3. Adjust the date if necessary.

4. Input the exchange rate for one or more already defined From currencies.

5. Click Apply to save your changes, or Reset to remove them.

6. To add rates for additional dates, repeat steps 2 through 5.

In the From Currency Pane
1. Click the From currency node. 

2. In the pane, click the Add Row button.

A new row is added to the spreadsheet. The current date appears in the Date 
field.

3. Adjust the date if necessary.

4. Input the value that represents the exchange rate per unit of the corresponding 
To currency.

5. Click Apply to save your changes, or Reset to remove them.

6. To add rates for additional dates, repeat steps 2 through 5.

Note: Be sure to run the rate validation process afterward. Rate 
validation status is shown in the Status column in the From 
Currency pane. See "Validating Exchange Rate Relationships" later 
in this chapter.
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Viewing and Printing Floating Exchange Rate History
Rate Manager displays exchange rate history for the last month unless you select 
otherwise from the select a date range pull-down menu (in the pane).

Viewing a Graph
To view a graph of your selected data, click the Display Graph check box. The graph 
appears on top of the spreadsheet.

The horizontal axis shows the dates within your range, while the vertical axis shows 
the exchange rates. Exchange rates for each From currency are plotted accordingly.

The graph is displayed full size. You can reduce the height by clicking the upper 
boundary and dragging it downward. Once reduced you can raise it, but it will not 
return to the original display height at that viewing. 

To exit the graph, uncheck the Display Graph check box.

Printing
To print the spreadsheet, do one of the following.

■ Click File -> Print.

■ Click the Print icon.

If you are viewing a graph, Rate Manager prints the spreadsheet followed by the 
graph.

Modifying or Deleting Floating Exchange Rate History
You can modify or delete one or more rates as follows: 

In the To Currency Pane 
1. Double-click the appropriate cell and manually modify or delete the contents. 

You can leave the cell empty or input a new rate.

2. To delete rates for all From currencies on a particular date, click the appropriate 
row, then click the Delete Row button.

The row appears gray. 

3. Click Apply to save your changes or Reset to erase them.
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In the From Currency Pane
1. Click the rate or row you want.

2. Delete the rate manually, or click the Delete Row button. 

After clicking Delete Row, the row becomes gray.

3. To modify or delete another rate or row, repeat the preceding steps. 
Use caution, because deleting all rows causes the exchange rate relationship to end and the From currency node to disappear.

4. Click Apply to complete the deletion or Reset to cancel it.

Using the Fixed Multiple Exchange Rates Pane
Clicking a Parent currency node produces a pane to the right. The pane contains a 
spreadsheet and other tools for managing exchange rates for that currency.

Note: If you want to delete all history for that relationship, you 
can delete a From currency node from the tree.
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Adding Fixed Exchange Rates to Existing Relationships
You can add rates at either the Parent or Child currency node level.

In the Parent Currency Pane
1. Click the Parent currency node.

2. In the pane, click the Add Row button.

The New Fixed Exchange Rate dialog box appears.

3. Select a currency from the Child Currency pull-down menu.

The Parent Currency selection is preset.

4. In the Beginning Date field, today’s date appears by default. Adjust the date if 
necessary.

5. In the End Date field, do one of the following:

■ If the end date is unknown, do nothing. The default setting is None and the 
date field remains blank.

■ To input a date, click the field. A pull-down menu appears. Click Set and 
adjust the date as necessary.

6. Input the exchange rate.

7. Click OK, or Cancel to exit.

A new row is added to the spreadsheet, and the new data appears red.

8. Click Apply to save the data or Reset to erase it.

The row is placed in alphabetical order by Child currency and in chronological 
order. The data changes from red to black. 

Note: Be sure to run the rate validation process afterward. Rate 
status is shown in the Status column in the Parent and Child 
currency panes. See "Validating Exchange Rate Relationships" later 
in this chapter.

Note: A currency can be a Child to only one Parent at a time. An 
error message appears when new dates overlap existing ones. 
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In the Child Currency Pane
1. Click the Child currency node. 

2. In the pane, click the Add Row button.

A new row, containing the current date, is added to the spreadsheet. 

3. Adjust the From Date if necessary.

4. In the To Date field, do one of the following:

■ If the to date is unknown, do nothing. The default setting is None and the 
date field remains blank.

■ To input a date, click the field. A pull-down menu appears. Click Set and 
adjust the date as necessary.

5. Input the value that represents the exchange rate per unit of the Parent 
currency.

6. To add rates for additional dates, repeat steps 2 through 5.

7. Click Apply to save your changes or Reset to remove them.

Viewing and Printing Fixed Exchange Rate History
Rate Manager displays all exchange rate history unless you select otherwise from 
the select a date range pull-down menu (in the pane). 

To print the spreadsheet, do either of these:

■ Click File -> Print.

■ Click the Print icon.

Modifying or Deleting Fixed Exchange Rate History
You can modify or delete one or more rates as follows: 

In the Parent Currency Pane 
1. Double-click the cell and modify or delete the contents. Or click the row and 

click Delete Row.

After you click Delete Row the row turns gray.

2. Click Apply to save your change or Reset to restore the previous data.
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In the Child Currency Pane
1. Click the appropriate row.

2. Delete the rate manually, or click the Delete Row button. 

After clicking Delete Row, the row becomes gray.

3. To delete another rate, repeat Steps 1 and 2.

4. Click Apply to complete the deletion or Reset to escape.

Validating Exchange Rate Relationships
Run the exchange rate validation process after you add or modify exchange rate 
data. You can run it immediately or schedule one or more to be run in the future. 

Each exchange rate is placed in one of the following statuses: 

Only exchange rates in Valid status are available for processing and they are not 
subject to future validation unless you edit them. (When a Valid rate is modified its 
status changes to Not Yet Validated.) 

Valid exchange rates from all active currencies to all reporting currencies are 
available for processing in other OFSA applications. Some of these rates may come 
from the validated direct input, others are calculated based on relationships with 
other rates. To support triangulation, all fixed exchange rates are available for all 
currencies that make up a conversion that needs to be triangulated. In addition, a 
direct exchange rate between each Child currency and each reporting currency is 
calculated and supplied to support quick access to exchange rates. If a Child 
currency is a reporting currency, then exchange rates are calculated for all currencies 
having an exchange relationship with the Parent currency.

Note: If you want to delete all history for that relationship, you 
can delete a Child currency node from the tree.

Status Description

Not Yet Validated The exchange rate has not yet been validated.

Processing The validation process is underway. 

Valid The exchange rate has been validated.

Invalid The exchange rate has violated one or more acceptance rules.
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To see the validation status of an exchange rate look in the Status column of From, 
Parent, or Child currency panes.

Exchange Rate Validation Criteria
In the rate validation process all exchange rate relationships in the database are 
examined for compliance with the following criteria. Error messages and warnings 
are displayed if one or more criteria are not met. (See "Viewing the Messages" later 
in this chapter.)

1. If a currency is defined as a Child in a fixed exchange relationship then it must 
not be in any floating (standard) exchange rate relationship at the same time. 
Consequently all floating exchange rates to or from the Child currency must be 
defined through the Parent currency. If this criterion is not met then Rate 
Manager displays this message: Invalid fixed relationship—Child currency exists in 
a standard exchange rate within the same time period.

2. A Child currency within a fixed relationship must not be a Child currency in 
any other fixed relationship during the same time period. If this criterion is not 
met then this message is displayed: Invalid fixed relationship—Child currency 
already exists in a fixed relationship for same time period.

3. A circular relationship must not exist. In other words, a Child currency cannot 
link back to its Parent in any other fixed rate relationship within the same time 
period. If it does, then this message appears: Invalid fixed relationship creates 
circular relationship with other fixed exchange rates.

4. Regarding new floating (standard) exchange rates, From and To currencies 
must not exist as Child currencies within any fixed exchange rate relationships. 
If this criterion is not met then this is displayed: From/To/Both currency(ies) in 
new exchange rate already exist in a fixed relationship for the same time period.

5. If any exchange rate is equal to 0, then a warning message is displayed. 
Generally speaking, 0 is a valid value. You can use it, for example, to designate 
an exchange rate with a currency of a country that no longer exists.

If two exchange rate relationships fail to meet these criteria then both of them will 
be labeled Invalid. (Exception: if one of the relationships is already in Valid status, 
then the other one will be labeled Invalid.) For example, if a currency is defined as a 
Child in a fixed rate relationship and is also defined as being in a floating 
relationship at the same time, then both fixed and floating rates for that currency 
will be labeled Invalid.
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If there are both direct and inverse floating exchange rates defined for any two 
currencies (in other words, one currency is both a To and a From currency in 
relation to the other), then both relationships will be marked Valid.

Running an Exchange Rate Validation
You can run a validation immediately or schedule one or more for later. The 
validation status is shown in the Status column of the From, Parent, and Child 
currency panes.

Running a Validation Immediately
1. Click Tools -> Run -> Exchange Rate Validation.

The job launch is successful alert appears, confirming the launch.

2. Click OK.

The rate status is reflected in the Status column of the appropriate pane. 

Any error messages or warnings are displayed in the Messages window. (See 
"Viewing the Messages" following.)

Scheduling One or More Validations
To schedule a future validation, or to schedule validations on a recurring basis, do 
the following:

1. Click Tools -> Schedule.

The Scheduler window appears.
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2. Click the Scheduled check box.

An unchecked box means that no job is scheduled to run.

3. In the Recurring check box, select one:

■ To run the validation once, uncheck the box. Go to Step 6.

■ To schedule the validation on a recurring basis, check the box.

4. In the Repeat Every field, input a positive integer.

5. From the Time Unit pull-down menu select Hour, Day, Week, or Month.

6. In the Next Run field, input the date and time for the next validation to be run.

7. Click Apply to set the schedule as specified or Reset to drop your changes.

Any error messages or warnings generated during the validation process are 
displayed in the Messages window. (See "Viewing the Messages".)

8. To exit the Scheduler, click its exit icon (X).

Viewing the Messages
Any error messages or warnings generated during the exchange rate validation 
process are displayed in the Messages window. 

To access the Messages window, click Tools -> Messages.
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The Messages window includes these fields: 

To exit the window, click the Exit icon (X) in the Messages window title bar.

For more information about the exchange rate validation process, refer to the Oracle 
Financial Service Technical Reference Manual.

Field Description

Run Time The start time of the latest run appears by default. Click the 
drop-down list to view other jobs run.

End Time Ending time of the specified run.

User Identification of user who scheduled the run.

Job Number Job number for the specified run.

Message A short description of the error, warning, or status.

Severity One or more of the following indicators can appear: Non-Fatal 
Error, Fatal Error, Warning, or Status.

Timestamp Time the message was generated.

Context A more detailed description of the error, warning, or status.
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adding, 5-10
modifying or deleting, 5-11
node, 5-2
printing, 5-11

Fixed Multiple Exchange Rates pane, 5-9
floating exchange rate relationships

adding, 5-3
deleting From currency nodes, 5-6
deleting To currency nodes, 5-5

floating exchange rates
adding, 5-7
graphs, 5-8
modifying or deleting, 5-8
node, 5-1
printing, 5-8

Floating Multiple Exchange Rates pane, 5-6
functional currency, 2-1, 3-1, 3-2

G
graphs

floating exchange rates, 5-8
interest rates, 4-8

H
Ho and Lee term structure model, 4-9

I
icons, Rate Manager, 1-7, 1-8
inputting term structure parameter data, 4-10
interest rate code pane, 4-4
interest rate codes

adding, 4-1
deleting, 4-3
reference, 3-6
tree, 1-5, 4-1

interest rates
adding, 4-7
attributes, 2-2
deleting, 4-8
modifying, 4-8
printing, 4-8, 4-9

ISO-defined currencies, 2-1, 3-2

L
long run rate, 4-9

M
mean reversion speed, 4-9
menu commands, 1-6, 1-7
menus

Actions, 1-6
Edit, 1-6
File, 1-6
Help, 1-7
Tools, 1-7
Window, 1-7

Merton volatility, 4-9
Messages window, 5-15, 5-16
messages, viewing exchange rate validation, 5-15
modifying interest rates, 4-8
modifying term structure parameter data, 4-11

N
nodes

(other) active currencies, 3-1
Child currency, 5-6
fixed rates, 5-2
floating rates, 5-1
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From currency, 5-6
functional currency, 3-1
Parent currency, 5-5
reporting currencies, 3-1
To currency, 5-5

O
Oracle Financial Data Manager, 1-2
Oracle Financial Services Applications, 1-1, 1-2
other active currencies

See currencies, active

P
panes

currency, 3-5
Fixed Multiple Exchange Rates, 5-9
Floating Multiple Exchange Rates, 5-6
interest rate code, 4-4

Parameters tab, 4-9
printing

fixed exchange rate history, 5-11
floating exchange rate history, 5-8
interest rates, 4-8
term structure parameter data, 4-11

R
Rate Manager tree, 1-5
Rate Manager window, 1-5
Rates tab, 4-7
reference interest rate code, 3-5, 3-6
reporting currencies, 3-1, 3-2
reporting currency check box, 3-5, 3-6
rules for adding interest rate terms, 4-5

S
Scheduler, exchange rate validation

See exchange rate validation

T
tabbed pages (interest rate code pane)

Attributes, 4-4

Parameters, 4-9
Rates, 4-7
Terms, 4-5

term structure models
Extended Vasicek, 4-9
Ho and Lee, 4-9
Merton, 4-9
Vasicek, 4-9

term structure parameters, 2-2
criteria, 4-10
deleting data, 4-11
inputting data, 4-10
modifying, 4-11
viewing and printing, 4-11

Terms tab, 4-5
terms, interest rate

adding, 4-6
deleting, 4-6
rules, 4-5

trees
currencies, 1-5, 3-1
exchange rates, 1-5, 5-1
interest rate codes, 1-5, 4-1
Rate Manager, 1-5

V
valid interest rates, range of, 4-8
validating exchange rates

See exchange rate validation
Vasicek

term structure models, 4-9
volatility, 4-9

volatility
Merton, 4-9
Vasicek, 4-9

W
windows

Messages, 5-15
Rate Manager, 1-5
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